根据错误消息,您的 Node.js 版本不符合 typescript@5.2.2 所需的最低 Node.js 版本。TypeScript 5.2.2 要求 Node.js 版本 >=14.17,但您的系统上的 Node.js 版本是 v12.22.12

为了解决这个问题,您可以考虑升级 Node.js 到 >=14.17 版本,然后再安装 TypeScript。以下是一些步骤来升级 Node.js:

  1. 首先,您可以使用 nvm(Node Version Manager)来管理 Node.js 版本。如果您尚未安装 nvm,您可以按照以下步骤安装它:
1
curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.39.1/install.sh | bash

或者使用 wget 安装:

1
wget -qO- https://raw.githubusercontent.com/nvm-sh/nvm/v0.39.1/install.sh | bash
注意:请查看 `nvm` 的官方网站以获取最新版本的安装脚本链接。
  1. 安装完 nvm 后,关闭并重新打开终端窗口以确保 nvm 生效。
1
source ~/.bashrc

查看版本:

1
nvm --version

列出版本

1
nvm ls
  1. 接下来,安装所需的 Node.js 版本。请运行以下命令:
1
nvm install 14.17.6
  1. 使用以下命令将新安装的 Node.js 版本设置为默认版本:
1
nvm use 14.17.6
  1. 确认 Node.js 版本是否升级成功,可以运行以下命令检查 Node.js 和 npm 版本:
1
2
node -v
npm -v
确保它们显示了新的版本号。
  1. 最后,重新运行以下命令来安装 TypeScript:
1
npm install -g typescript@latest
  1. 初始化一个新的 package.json 文件
1
npm init

现在,您应该能够成功安装 TypeScript 并编译您的项目。如果您在这些步骤中遇到任何问题,请随时提供更多信息,以便我可以提供进一步的帮助。